Murat TATAR God saves lost souls , I save lost passwords

12Mar/130

Eski joomla sürümlerinde php 5.3 hatasi Warning: Parameter 3 to showItem() expected to be a reference …

Merhaba;

Joomlanın eski sürümlerindeki php5.3 e gecişlerde cıkan Warning: Parameter 3 to showItem() expected to be a reference ... hatasının cözümü aşagidaki şekildedir.

/includes/Cache/Lite/Function.php:dosyanızdaki aşagıdaki satirları yenileriyle degiştirmeniz yeterli olucaktir.

1.
eski:  $result = call_user_func_array(array($class, $method), $arguments);
yeni:      $result = call_user_func_array(array($class, $method), &$arguments);
2.
eski:  $result = call_user_func_array(array($$object_123456789, $method), $arguments);
yeni:      $result = call_user_func_array(array($$object_123456789, $method), &$arguments);
3.
eski:  $result = call_user_func_array($target, $arguments);
yeni:      $result = call_user_func_array($target, &$arguments);
Umarim işinize yarar 😉
   
Copy Protected by Chetan's WP-Copyprotect.