Murat TATAR God saves lost souls , I save lost passwords

12Şub/130

Joomla 1.0 sürümünü php 5.3 e uyarlama

Merhaba;

Bircok hosting firması artık yavaş yavaş php 5.3 sürümüne gecmeye başladı. Bununla ilgili olarak joomla 1.0 sürümlerinin php 5.3 e geçişlerinde bir cok sorun cıkmakta. Benim size önerim joomla 1.5 e sitenizi upgrade etmeniz yönündedir. Joomla 1.6 sürümüde şu an mevcut fakat bir cok eklenti ve tema 1.5 sürümüne göre yapildigindan 1.5 sürümünü yüklemeniz iyi olucaktir.

Fakat bu şekilde sitenizi upgrade edip diger eklentilerinizin uyumlulugu yada tema uyumlulugu ile ugraşmak istemiyorsanız aşagıda size nasil joomla 1.0 sürümünü php 5.3 e sorunsuz bir şekilde uyarliyacaginizi anlaticam.

Öncelikle Ftp nizden fuction.php dosyanızı bulmanız gerekmekte. Örnegin cpanellerde genelde şu locationda bulunur : /public_html/includes/Cache/Lite

Dosyayi actiktan sonra aşagidaki kodu bulup;

$arguments = func_get_args();

Bu kodla Degiştiriyorsunuz

$arguments = func_get_args();
$numargs = func_num_args();
for($i=1; $i < $numargs; $i++){
$arguments[$i] = &$arguments[$i];
}

Yapmanız gereklenlerin tamamı bu kadar. Sitenizin görünmeyen bir cok postu bu işlemi yaptiktan sonra tekrar görünür olucaktir. Sitenizi artık sorunsuz bir şekilde php 5.3 sürümünde caliştirabilirsiniz.

   
Copy Protected by Chetan's WP-Copyprotect.